Skip to main content
← All vulnerabilities
CVE-2022-35737RUSTSEC-2022-0090BIT-SQLITE-2022-35737GHSA-JW36-HF63-69R9

SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.39.2, 0.25.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • sqliteBitnami

    From 1.0.12 · fixed in 3.39.2

  • libsqlite3-syscrates.io

    fixed in 0.25.1

  • libsqlite3-syscrates.io

    From 0.0.0-0 · fixed in 0.25.1

References 6

sqlite.org

kb.cert.org

security.netapp.com

blog.trailofbits.com

security.gentoo.org