CVE-2022-35649GHSA-XP2F-9MX3-3C6PBIT-MOODLE-2022-35649
The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.9.15, 3.11.8, 4.0.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Moodle
Version range not reported
- moodle/moodlePackagist
From 3.9 · fixed in 3.9.15
- moodle/moodlePackagist
From 3.11 · fixed in 3.11.8
- moodle/moodlePackagist
From 4.0 · fixed in 4.0.2