Skip to main content
← All vulnerabilities
CVE-2022-34257GHSA-RG7P-WMGJ-F374BIT-MAGENTO-2022-34257

Adobe Commerce Stored XSS Arbitrary code execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.7-p4, 2.4.5, 2.4.3-p3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.4; through 2.3.7-p3; through 2.4.3-p2

  • magento/community-editionPackagist

    From 2.3.0 · fixed in 2.3.7-p4

  • magento/community-editionPackagist

    From 2.4.4 · fixed in 2.4.5

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.3-p3

References 1

helpx.adobe.com