Skip to main content
← All vulnerabilities
CVE-2022-34256GHSA-R7MM-GRF3-5FJVBIT-MAGENTO-2022-34256

Adobe Commerce Improper Authorization Privilege escalation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.7-p4, 2.4.5, 2.4.3-p3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.4; through 2.3.7-p3; through 2.4.3-p2

  • magento/community-editionPackagist

    From 2.3.0 · fixed in 2.3.7-p4

  • magento/community-editionPackagist

    From 2.4.4 · fixed in 2.4.5

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.3-p3

References 1

helpx.adobe.com