CVE-2022-34255GHSA-X95X-F4G9-MM85BIT-MAGENTO-2022-34255
Adobe Commerce Improper Access Control Privilege escalation
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.7-p4, 2.4.5, 2.4.3-p3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in Privilege escalation. An attacker with a low privilege account could leverage this vulnerability to perform an account takeover for a victim. Exploitation of this issue does not require user interaction.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.4; through 2.3.7-p3; through 2.4.3-p2
- magento/community-editionPackagist
From 2.3.0 · fixed in 2.3.7-p4
- magento/community-editionPackagist
From 2.4.4 · fixed in 2.4.5
- magento/community-editionPackagist
From 2.4.0 · fixed in 2.4.3-p3