Skip to main content
← All vulnerabilities
CVE-2022-33980GHSA-XJ57-8QJ4-C4M6

Apache Commons Configuration insecure interpolation defaults

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.8.0
5 proofs of concept on GitHub

Summary

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Commons Configuration

    fixed in 2.8.0

  • org.apache.commons:commons-configuration2Maven

    From 2.4 · fixed in 2.8.0

References 10

lists.apache.org

openwall.com

security.netapp.com

debian.org

GitHub · HKirito/CVE-2022-33980

GitHub · P0lar1ght/CVE-2022-33980-POC

GitHub · joseluisinigo/riskootext4shell

GitHub · sammwyy/CVE-2022-33980-POC

GitHub · tangxiaofeng7/CVE-2022-33980-Apache-Commons-Configuration-RCE