Apache Spark shell command injection vulnerability via Spark UI
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- Fix
- Fixed in 3.2.2, 3.1.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache Spark, a widely used open-source data processing framework, is affected when its web UI has access control lists enabled and an authentication filter in use. An attacker could exploit this flaw to run arbitrary operating system commands with the same privileges as the Spark process, potentially taking full control of the affected server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apache Software Foundation Apache Spark
From 3.0.3 and earlier · through 3.0.3; From 3.1.1 to 3.1.2 · through 3.1.2; From 3.2.0 to 3.2.1 · through 3.2.1
- org.apache.spark:spark-parent_2.12Maven
through 3.0.3
- org.apache.spark:spark-parent_2.12Maven
From 3.1.1 · fixed in 3.2.2
- pysparkPyPI
fixed in 3.1.3
- pysparkPyPI
From 3.2.0 · fixed in 3.2.2
- pysparkPyPI
fixed in 3.1.3; From 3.2.0 · fixed in 3.2.2