Skip to main content
← All vulnerabilities
CVE-2022-3325

Improper access control in the GitLab CE/EE API affecting all versions starting from 12.8 before 15.2.5, all versions starting from 15.3 bef

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.4.1, 15.3.4, 15.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper access control in the GitLab CE/EE API affecting all versions starting from 12.8 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1. Allowed for editing the approval rules via the API by an unauthorised user.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 15.4 · fixed in 15.4.1; From 15.3 · fixed in 15.3.4; From 12.8 · fixed in 15.2.5

References 2

gitlab.com