Skip to main content
← All vulnerabilities
CVE-2022-32214GHSA-Q5VX-44V4-GCH4BIT-NODE-2022-32214BIT-NODE-MIN-2022-32214

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP re

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.20.0, 16.20.0, 18.5.0, 6.0.7
None on Exploit-DB, Metasploit or GitHub

Summary

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS).

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • NodeJS Node

    From 4.0; From 5.0; From 6.0; From 7.0; From 8.0; From 9.0; From 10.0; From 11.0; From 12.0; From 13.0; From 14.0 · fixed in 14.20.0; From 15.0; From 16.0 · fixed in 16.20.0; From 17.0; From 18.0 · fixed in 18.5.0

  • llhttpnpm

    fixed in 6.0.7

References 3

nodejs.org

hackerone.com

debian.org