Skip to main content
← All vulnerabilities
CVE-2022-32167GHSA-FG25-GQ9G-32MX

Cloudreve - Stored XSS

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.6.0-beta1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Cloudreve Cloudreve

    From 3.0.0-beta; through 3.5.3

  • github.com/HFO4/cloudreveGo

    From 1.0.0 · through 2.0.0

  • github.com/cloudreve/Cloudreve/v3Go

    From 3.0.0 · fixed in 3.6.0-beta1

References 1

mend.io